しばらく触っていなかったxcodeプロジェクトを久しぶりに改修しようとして新しいライブラリ(SugarRecord/CoreData)を
cocoapodでインストールしようとした際に下記のようなエラーが起こった。
>CocoaPods could not find compatible versions for pod "Result"
~/project/06_codeapp/bk/rental-app-ios (sample-mvvm *+)$ pod install
Analyzing dependencies
[!] CocoaPods could not find compatible versions for pod "Result":
  In snapshot (Podfile.lock):
    Result (= 3.2.4, ~> 3.0)

  In Podfile:
    Moya (~> 13.0) was resolved to 13.0.0, which depends on
      Moya/Core (= 13.0.0) was resolved to 13.0.0, which depends on
        Result (~> 4.1)

    SugarRecord/CoreData was resolved to 3.1.2, which depends on
      Result (~> 3.0)

これを見た私は、

てっきり、cocoapodが壊れた・gemをアップデートしろ・xcodeのバージョンが上がってしまったなどかと思ったが、

それでは解決できなかった。

そして調べていくと

MoyaとSugarRecordの指定しているバージョン(おそらくswift?)が齟齬っているのが原因だった。

Moyaのバージョンを最新の14にしたら通過したのだ。

ちょっと詰まったので、メモとして記事にしておく。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください